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Getting Started 

Logger Pro Requirements 

To use Logger Pro, you must have the following equipment: 

• Windows 98®, 2000, ME, NT, or XP on a Pentium® processor or equivalent, 
133 MHz, 32 MB RAM, 25 MB of hard disk space, for a minimum 
installation. 

• Mac OS® 9.2, or Mac OS X (10.2 or newer), with 25 MB of hard 
disk space for a minimum installation. 

Using the movie feature of Logger Pro will require a faster processor and an 

additional 100 MB of hard disk space. Movies are supported by QuickTime®, which 
you can add during Logger Pro installation. 

Note: Logger Pro cannot be used with the ULI or Serial Box interface.  

Load Logger Pro 

Windows 

• Place the Logger Pro CD in the CD-ROM drive of your computer. 

• If you have Autorun enabled, the installation will launch automatically; otherwise 
choose Settings→Control Panel from the Start menu. Double-click on 
Add/Remove Programs. Click on the Install button in the resulting dialog box. 

• The Logger Pro installer will launch, and a series of dialog boxes will step you 
through the installation of the Logger Pro software. It is recommended that you 
accept the default directory. 

Macintosh 

• Place the Logger Pro CD in the CD-ROM drive of your computer and double-
click on the CD icon. 

• Double-click the “Install Logger Pro” icon and follow the instructions. 

Getting Everything Ready 

Using a computer, you will need the following to collect data with Logger Pro: 

• A free USB or serial port on your computer 

• A Vernier LabPro ® interface: 

To collect data, you will need a Vernier LabPro with its power supply 
and USB or serial cable (cables provided with LabPro). 

   Or, 

• Go!TM Link 

Go! Link is a single-channel interface that connects directly to a 
computer's USB port.    

 



 3 

• At least one sensor:  

Sensors are connected to the LabPro or Go! Link.. A Stainless Steel 
Temperature Probe is good choice for initial testing of Logger Pro. The 
Voltage Probe included with the LabPro interface can also be used.  

 Or, 

• Go! Temp 

The Vernier Go! Temp is a temperature probe that connects directly to 
the USB port of your computer. No interface is needed. This sensor 
comes with the Logger Lite software.  

      Or, 

• Ohaus Balances 

Logger Pro allows you to collect mass data from select models of 
Ohaus balances. 

 
Initial Setup 
Note: The following setup instructions are for the LabPro interface. They are similar 
to the Go! Link interface instructions. Choose Logger Pro 3 Help from the Help 
menu for further details. 

Before launching Logger Pro, you should: 

• Power the LabPro using the AC power supply or AA batteries. 

• Connect a sensor to LabPro.  

 

• Connect the USB or serial cable to LabPro.  

• Attach the other end of the interface cable to any 
unused serial port or USB port on your computer.  

 

Start up Logger Pro 
Locate the Logger Pro icon and double-click on it. Mac OS X users can find the 
icon in the Logger Pro folder created during installation. 
 

Note: The first time that you run Logger Pro with your LabPro interface, a 
message may appear notifying you of an update to the LabPro operating system. 
You will need to proceed with this update. This may take several minutes.* The 
process is significantly faster if you use the USB rather than the serial cable. 

* Important: Do not interrupt this update. 
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Logger Pro can collect data from multiple interfaces and devices. If Logger Pro has 
successfully detected these devices, you will see the device icon (see figure below). 
Also, if an auto-ID sensor is attached, the current sensor reading will appear below 
the toolbar (as shown in the figure).  

 
Nice job! You have successfully set up your equipment and installed Logger Pro. 
Keep reading for instructions on the various ways to collect and obtain data. You 
will also learn how to use Logger Pro’s powerful features, such as data analysis, 
movies, and customizing your experiments. 
 

Quick Reference Manual 
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Introduction 

Logger Pro is a program that allows you to collect and analyze data from Vernier 
LabPro, Go! Link, Go Temp, and Ohaus balances. Among its many features, data 
may be manually entered from the keyboard, pasted from the clipboard, or retrieved 
from a file saved on disk. Logger Pro is also a document creator, with the ability to 
include several pages in one document. With Logger Pro you can also: 

• Perform data analysis, such as statistical analysis, curve fitting, and 
calculated columns. 

• Add pictures to lab reports. 

• Add movies and synchronize movies with data collection.  

• Import data collected with TI handhelds. 

• Import data collected with Palm OS® handhelds. 

• Manually enter data. 

• Export data to Excel® or other spreadsheets. 

• Have students draw a prediction on a graph and see how well the 
experimental data matches it. 

• Use video analysis to create a graphical representation of the motion you 
see in a movie. 

The Help guide in the program provides complete details about Logger Pro. 
Tutorials are also included. Select Open from the File menu to access them.  
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Tutorials 
In Logger Pro, we have some great Tutorials that cover many of its features and 
menus. Simply choose Open from the File menu, then open the Tutorials folder: 

• Getting Started • Stats, Tangents, Integrals 
• Events with Entry • Curve Fitting 
• Motion Measurement • Linearization (Parts 1 and 2) 
• Manual Data Entry • Video Analysis 

All you need to do is open the tutorial file you want to try out, and then follow the 
on-screen instructions in that file. 

The extensive Help in Logger Pro provides detailed instructions for use of the 
program. The answer you are looking for may be just a mouse click or two away!  
____________________________________________________________________ 

Acquiring Data 
Use any of the following methods to acquire Logger Pro data. 
 
Collecting Data 
Before you can collect data, you should have already performed the following steps, 
as outlined in the Getting Started section earlier in this booklet: 

Note: The following setup instructions are for the LabPro interface. They are similar 
to the Go! Link interface instructions. Choose Logger Pro 3 Help from the Help 
menu for further details. 

• Power the LabPro using the AC power supply or AA batteries. 
• Install Logger Pro 
• Connect a sensor to LabPro 
• Connect LabPro to an available serial or USB port 
• Start up Logger Pro 
• Update LabPro’s operating system (if necessary) 

Configure Logger Pro for Your Experiment 
Before you can collect data, you will want to have Logger Pro configured properly 
with a data-collection rate and length of collection that is appropriate for your 
experiment. There are several ways to do this in Logger Pro. 

• Auto-ID Sensors  With auto-ID sensors, all you need to do is connect the sensor 
to one of the LabPro channels and start up Logger Pro software. The sensor will 
be identified, and default data-collection parameter loaded for that sensor. You are 
ready to click the  button and begin data collection! 

• Probes & Sensors experiment files  If you are using an older Vernier sensor that 
is not auto-ID, or if you want to use some other pre-configured file, you will find 
the Probes & Sensors folder very useful. Choose Open from the File menu, and 
open the Probes & Sensor folder. There you will find a folder for each of the 
Vernier sensors. Open up a file with a name that best fits the data collection you 
wish to perform. 
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• Vernier Lab Book experiment files  When you choose Open from the File menu, 
you will see a series of folders with Vernier lab book experiment files, such as 
Biology with Computers, Chemistry with Computers, etc. Each of these folders 
contains 30-40 experiment files, each corresponding to an experiment in each of 
our lab books.  

• Sensor Dialog  This dialog, 
called up by clicking the 
respective button in the 
toolbar ( , for example) 
shows your sensor 
information, the units and 
current readings. If an Auto-
ID sensor is connected, 
Logger Pro will identify the 
sensors connected to your LabPro. Or, if your sensor is not auto-ID, you can 
simply drag the sensor to the appropriate channel and drop it. 

Collect Data 

Click . Logger Pro will begin plotting data in the graph window. Tip: 
Normally, the data collection stops at the time indicated on the time axis. You can 
stop the data collection early by clicking . If you discover you want the data 
collection to go even longer, you can add additional time by choosing Extend 
Collection from the Experiment menu. 

Now that you have collected data, there are many things you can do with it. Keep 
reading for descriptions of some of the most popular Logger Pro features. 

Storing Data 

The Store Latest Run option in the Experiment menu saves the most recently collected 
data in memory, allowing you to do another collection without losing the first one.  

The run labeled “Latest” always contains the most recently collected data, and is 
overwritten when you collect more data. When you store the latest run, a new data 
set named Run 1, Run 2, etc, is created and the values of the latest data set are copied 
to it. Columns in the latest data set are drawn with thick lines on the graph, while 
other columns are drawn with thin lines.  

Note: Using Store Latest Run does not save data on disk, nor will it preserve your 
data between sessions or when you turn off your computer. You must select Save As 
from the File menu to save all your data permanently. 

Data Collection and Modes 

You are not limited to time-based data collection. 
Choose Data Collection from the Experiment menu 
to modify data collection parameters for your 
experiment. See Logger Pro’s Help for information 
about your choices. 

Time Based: Set the data collection rate as a 
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function of time.  

Events With Entry: A data point is recorded whenever the Keep button is clicked. 
You are then prompted to enter values for a new data column. 

Selected Events: A data point is recorded whenever the Keep button is clicked. 

Digital Events: You can set data collection to run continuously (until the Stop 
button is clicked) or at a pre-determined number of events. 
 

Manually Entering and Importing Data 

Besides live data collection, you have several options for getting data into the 
program. You can also manually enter your own data, import data from devices, and 
set up a device for remote collection. 

Manually Entering Data 

You can type data directly into the data table from the 
keyboard. To manually enter data, disconnect all 
interfaces, and start Logger Pro. Click on a cell and type in 
a number. You can use the mouse or the Enter/Return key 
to move and edit within the table. Your values will also be 
plotted on the graph. 

Importing Data 
• You can import data from Texas Instruments graphing 

calculators, LabPro, or CBL 2 devices using the TI-GRAPH 
LINK cable. Do so by choosing Import From... TI Device 
from the File menu or clicking the  button. The dialog 
box to the right will appear with the available data lists for 
importing. 

• Data collected and stored in the LabPro interface using its 
Quick Setup feature can be imported via the serial or USB 
cable. Do so by choosing Import From... LabPro from the 
File menu. 

• Data collected with a Palm OS handheld running the 
Vernier Data Pro program can be imported by first starting 
up Logger Pro, placing the Palm OS handheld into its 

HotSync® cradle, and pressing the HotSync button. Data 
are then displayed in the table and graph of Logger Pro, 
where you can print or do further analysis. 

Remote Data 
LabPro can collect data without a computer attached. You can use Logger Pro to set 
up the experiment, detach LabPro, collect data remotely, then reattach LabPro to the 
computer to retrieve the data. Select Remote→Setup from the Experiment menu to 
set up LabPro for remote data collection.  
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Finding Your Way around Logger Pro 
Take a few moments to get familiar with Logger Pro’s layout. 

Logger Pro Screen and Toolbar 
Toolbar: The toolbar contains buttons for the most commonly used features of 
Logger Pro. All of the features in the toolbar are also available in the menus. As you 
move the pointer across a button, you are given a short description of each feature. 

 

 

Menu Bar: Logger Pro has a menu bar across the top of the main window. Use the 
menu bar to access all of the software’s features. 

 

Object: You can add new objects using the items in the Insert menu and modify 
them using the Options menu or by double-clicking on the objects. 

Graph: Available graphs include Cartesian (2-D), Histogram, FFT Graph. 
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Table: Displays data in data sets. 

Text: A small text editor. Use it to record notes for your file. 

Text Annotation: Allows you to enter and edit notes about the data. 

Meter: Displays the values of data columns in large digits, as a thermometer, gauge, 
or animated display. 

Movie: You can add a movie of an experiment to your page, then synchronize data 
collection to the movie. 

Picture: You can add a digital picture object to your page.  

Page: Logger Pro 3 has “pages.” These pages allow you to have different layouts of 
data in a single file. One page might contain a graph and table with five different 
data collections. On different pages you might perform comparisons between 
different collections or just go into each collection in more detail.  

Navigating Between Pages 

The previous page can be accessed by clicking the  button on the Toolbar. 

The next page can be accessed by clicking the  button on the Toolbar. 

You can also use the drop-down menu from the Toolbar and choose 
which page in a document you want to view. 
 

The Sensors Dialog 

 
This dialog, called up by clicking the respective button in the toolbar ( , for 
example) shows your sensor information, the units and current readings. 

Use the scroll bars in the Sensor Catalogs to view all sensors. 

By clicking in a Channel box with a displayed sensor, you may be able to:  

• Calibrate a sensor: Perform a new calibration. 

• Get sensor information: Includes collection details and calibration information. 

• Zero a sensor: Sets the current reading of a sensor to zero. 

• Choose sensor: Select another sensor for the channel.  
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• Change the Current Settings: Select the available units or calibration settings  

• Analog Out (CH 4 only): This channel can be used as a function generator.  

• Remove Sensor: Clears the channel of the sensor.  

Managing Your Page and Data 

There are numerous ways that you can customize the presentation of your data.  

Managing and Adjusting Objects 

Moving Objects: Select the object by clicking on it once. Move the 
cursor over the edge of the selected object until the cursor turns into 
a hand, then hold down the mouse button while grabbing and moving 
the object.  
 

Resizing Objects: Single-click on an object to select it. When an object is 
selected, its border becomes visible, along with eight resizing handles.  

Clicking and dragging a resize handle will resize the object in the 
appropriate direction.  
 

Graph Axes: Customize your graph by changing the columns that are displayed.  

1. Position the mouse over the X-axis or Y-axis label and click. A list of available 
columns will appear.  

2. Select the column you want displayed. If you want more than one column 
displayed, select More and check the boxes next to the desired columns. 

Graph Options: Double-click on the graph 
or select Graph Options from the Options 
menu to call up the Graph Options dialog. 
This allows you to change the graph object 
appearance, including point protectors, 
legend, line style, and other graph features. 
Click the Axis Options Tab to adjust scaling 
and select what columns are plotted. 

 
Working with Data 

Creating a Column: You can create a new 
column that is manually entered or based on 
calculations. The new column can calculate 
results based on other data in Logger Pro. 
Create a new column by selecting New 
Manual Column or New Calculated Column 
from the Data menu.  
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Selecting and Editing Cells in a Data Table:  
Manually-entered data and data collected using the Events with Entry mode can be 
edited. 

• To edit a single cell in a table, single-click in the cell.  

• To select a single cell in a table, click and drag the selection within that cell. 

• You can select entire columns by clicking on the title of the column. 

• You can select an entire row of data by clicking on the row numbers. 

The Data Browser 

The Data Browser is a container for all data in a Logger Pro 
file. In contrast, a given Data Table will not necessarily show 
all data columns. 

Data Browser Features:  
Drag and drop from the Data Browser to objects such as 
tables and graphs. Drag a column to a y- or x-axis to plot it 
there.  

When the Data Browser is “Active” (it’s been clicked on), 
edit menu items like Cut, Copy, Paste, etc. will apply to the 
selected items within the Data Browser.  

 

 

Analyzing Data 
The Analyze menu contains functions for examining and analyzing your data. A few 
of the most commonly used analysis functions are as follows: 

• Examine: Shows the x- and y-values of the data point closest to the mouse pointer. 

• Statistics: Calculates the minimum, maximum, mean, and standard deviation. 

• Curve Fit: Fits a user-defined function over the data. 

Several of the analysis features are available from the Toolbar. 

Additional Analysis Features 

Movie: You can synchronize data collection 
and a movie of the experiment so that as you 
Replay the movie, the data are replayed on 
the graph. 

Video Analysis: You can create a graphical 
representation of the motion you see in a 
movie. 

Histogram: Displays the distribution of 
values for a data set in bar graph format. 
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Strip Chart: Each new collected data point gets added to the right most edge of the 
graph. 

FFT: Gives the amplitudes of the frequency components of a data series, and 
displays a bar graph showing the amplitudes of the frequencies shown along the x-
axis. 

Setting Preferences 

The Preferences dialog box contains 
several options that pertain to the general 
operation of the software. These 
preferences will apply every time Logger 
Pro is launched. 

In Windows and Mac OS 9, choose 
Preferences from the File menu. In Mac 
OS X, choose Preferences from the 
Application menu. 

Printing 

Printing Graphs and Data 

1. Arrange the objects on the screen as you want them to appear on the paper. If 
you choose, you can print several graphs and data tables at once.  

2. Select Print from the File menu or click the  button on the toolbar.  

3. When the printer is ready, click OK in the Print dialog box. 
 

You can print the graphs and data tables individually by selecting Print Graph or 
Print Data Table from the File menu. 
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Where to Next? 
The extensive Help system in Logger Pro provides detailed instructions for the 
previous, and several other, commands. 

Also available are the Logger Pro Tutorials. Choose Open from the File menu to 
access them. These short tutorials are suitable for reference or for use in your 
classes. First-time users should work through one introductory tutorial and the 
advanced tutorials as needed.  

If you have questions as you are using our software, feel free to call or e-mail us. We 
will be happy to help! 
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